Galaxy Online II Today: 1    Total Posts: 601

Total:#5

Create Thread

[Off-Topic] exploring humorriods and planets

[Copy link] 4/937

#1
Posted on 6/25/15 6:25:15 AM | Show thread starter's posts only

Trying to explore humorroid to attack, but it won't open, and even if I try to explore another planet it won't open either. Not the first time this has happened. I have closed out and reopened, even restarted my laptop and it still does not work???

Signature
Steve
#2
Posted on 6/25/15 4:12:02 PM | Show thread starter's posts only

Humaroids can only be opened when they are under attack.

Signature
Like IGG on Facebook http://www.facebook.com/igg
Follow IGG on Instagram http://instagram.com/iggigotgames/
Like CC on Facebook http://www.facebook.com/CastleClash
Like COL2 on Facebook http://www.facebook.com/ClashofLordsII
Like DH on Facebook http://www.facebook.com/deckheroes
#3
Posted on 6/25/15 6:21:33 PM | Show thread starter's posts only

when I right click on the planet it won't bring up the pop up box for me to send fleets to attack.

Signature
Steve
#4
Posted on 6/27/15 12:06:56 AM | Show thread starter's posts only

You need to refresh game window everytime before sending to Huma. it might have expired time..

Signature
Like IGG on Facebook http://www.facebook.com/igg
Follow IGG on Instagram http://instagram.com/iggigotgames/
Like CC on Facebook http://www.facebook.com/CastleClash
Like COL2 on Facebook http://www.facebook.com/ClashofLordsII
Like DH on Facebook http://www.facebook.com/deckheroes
#5
Posted on 6/27/15 4:55:16 AM | Show thread starter's posts only

I have refreshed the game screen, logged out and back in, restarted my laptop several times. The best I can get is I can click on a planet next to mine and it will open to explore, but as soon as I move away from my planet nothing will open. Confused???

Signature
Steve